Clicky

StickyC
I'm trying out HoudahGeo with the AMOD AGL3080. I took several hundred pictures this afternoon with a Canon Powershot and had the AMOD running the entire time. I'm trying to geotag the photos I took but am having no luck.

I've got a 5.3mb log file from the AMOD, the track inspector shows 1 track with the correct start and end timestamps.

I've already imported all of the images into iPhoto '09.

The steps I'm taking are, dragging all the photos from iPhoto to HoudahGeo, they do all show up with the correct timestamps on them. I then open the log file from the AMOD. HoudahGeo displays the "Loading 1 track log file(s)" dialog for ~10 seconds, then quickly displays some preferences dialog which closes right away, I can't really tell what the options are in the dialog. I then get the "Geocode 127 images" dialog for another 15 seconds and it closes and the images are not tagged.
I've tried copying a few of the images out of iPhoto to the desktop and dragging them into HG and working with them that way, same result. I can manually geotag the images using the Map option. The time offset on the camera is correct (in the camera preferences).

Do I need to do some in-between step to the AMOD's log file? I'm pretty sure it's got the 2.2 firmware released in March. I was under the impression HG would parse it wouthout any translation.

0 0
kinnear3

I also use an AMOD AGL 3080, although I manage my photos with Aperture instead of iPhoto. I would suggest that you geotag your photo files before you import them into iPhoto. Substitute iPhoto for Aperture and simply navigate to the spot on your hard drive where you have HoudaGeo deposit your photos and everything should work out fine. Here is my workflow:

1. Utilize the Image Capture application to transfer my photo files from the memory card to a folder on my Desktop. (Image Capture is standard on every Mac. I do not use Aperture to load the photos onto the computer.)

2. Open HoudaGeo, click the "Add Images from File" button, navigate to the folder on my desktop and add the new images to HoudaGeo.

3. Connect my AMOD device to the Mac, click on "Load GPS data from file" in HoudaGeo (fourth button from the left), navigate to the geolog file on the geotracker, which appears as an external drive and load the log file or files into HoudaGeo, which, then geotags the photo files.

4. Click on "Reverse Geocode Images" (the button with two arrows pointing to the left, in order to add city, country and altitude.

5 Click on "Write EXIF/XMP/IPTC tags" and save the resulting folder in a place that I can find it.

6. Open Aperture, click Import, Local Files, navigate to the folder full of newly geocoded images and import them to Aperture. It is at this point that I adjust file names, add keywords, etc.

This workflow geotags the masters before they are even loaded into Aperture. It seems to work quite reliably.
Dave
0 0
StickyC
I'm stuck on step 4. When I go to geotag, I get the errors mentioned in the original post. I never was able to get that data set working with the images. Fortunately, most were taken in the same area, so I was able to manually tag them.

I've been too busy to try again with new data, but plan on doing a lot of traveling/shooting after the 4th of July weekend and will see what happens with that data.
0 0
houdah
Hi!

What are the exact problems you have with "Reverse Geocoding"? The problems described in the first post seem related to geocoding.

Please make sure you have the latest version of HoudahGeo. This should fix the issues described in the first post.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
StickyC
Okay, I must be doing something wrong. This week, I did a long distance on my MC with the Garmin Zumo and took quite a few pics. I made sure the GPS was on while I was taking pics so I'd have Track data.
Got back home, copied the pics directly from the camera to a folder, dropped that folder into HoudaGeo, copied the GPX file from the Zumo's SD card and clicked the Load GPS Data From File button. I selected the GPX file I'd copied from the SD card. The Loading 1 Track Log File(s) dialog came up for ~20 seconds, then the geotag parameter dialog quickly flashed up and went away. I then got the "Geocode 159 images" dialog for another ~20 seconds and it went away. All the images in the list are red and the program is still highlighting the Step 2 set of icons.

I tried selecting Geocode from Tracks and Waypoints in the Geocode menu, got the geotag paramter dialog, clicked OK, and still all the images are red.

I've tried breaking the GPX into smaller chunks, no luck. Tried re-processing it with GPSBabel to see if there was invalid data, no luck.

What am I doing wrong? This is getting more than a little frustrating.

0 0
houdah
Hi!

Please check the Track Inspector to see if the time span covered by the track overlaps with the times the photos were taken. All times shown in HoudahGeo respect the time zone setting made using the menu in the top right corner of the project window.

If time spans don't overlap, you have probably incorrectly configured the camera time zone in HoudahGeo.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
StickyC
The images are timestamped (according to the HoudaGeo screen) from July 7th through July 14th. The track log shows July 9th through July 17th (which is correct). My camera was not set for DST (1hr behind the GPS), so I use an offset of -3600 seconds. I would expect the images before July 9th to be missing data, but the images from the 9th through the 14th should be getting tagged.



Additionally, many of the links in the help are broken (pretty much all links, except for the Index).

0 0
houdah
Hi!

Please email me the track log and a sample image which you would expect to be geocoded using the track log. I will then be able to determine what is going wrong.

The help book indeed seems to be acting up. Thanks for letting me know.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
StickyC
Bah - The second set was entirely Idiot Operator error - the year on the camera was incorrect. Once I'd fixed that, the second set worked fine.

Now that I know how things are supposed to work (and thanks to Houdah's excellent support, have some tools to help fix issues), I'll try tagging the first set again (different camera, different GPS).

0 0