Hi Pierre!

I've been successfully using ACTPrinter 1.4 for Mac on a Mac mini server running Mac OS X 10.6.7 Server, printing to an iPad 2 running the latest version of ACTPrinter.  I've now installed ACTPrinter 1.4 for Mac on a MacBook Air running 10.6.8, trying to print to the same iPad, and I get as far as the attached screenshot.

But when I click OK, I instantly get a "Failed to print to device" error. The Console log just says this:

21/07/2011 PM 10:00:57    ACTPrinter Mac[30875]    name: aho's iPad2
21/07/2011 PM 10:01:23    ACTPrinter Mac[30875]    -[NSResponder presentError:modalForWindowelegateidPresentSelector:contextInfo:]: There are recovery options but no recovery attempter to interpret the user's choice of one of them. Ignoring the recovery options and suggestion.

There are no other log entries around that time period.

I then tried the following:
  1. printing to the same iPad from my Mac mini server again -- no problem.
  2. diff ~/Library/Preferences/com.houdah.ACTPrinterMac.plist from both server and Air -- no diff.
  3. deleted /Applications/ACTPrinter, ~/Library/Preferences/com.houdah.ACTPrinterMac.plist and ~/Library/PDF Services/Print to iPhone on the Air, then reinstalled using the same ACTPrinter zip file that I used on the server -- same problem as before.
  4. turned off Wi-Fi on my Air and connected to the same (home) subnet via Ethernet (since my server was wired, I wanted to eliminate this potential diff) -- same problem as before.

Any suggestions?  Does the Console log error above help, or do you need more info?

Thanks much!


Click image for larger version - Name: Screen_shot_2011-07-21_at_PM_10.41.24.png, Views: 9, Size: 129.31 KB
0 0

Sorry to hear you are experiencing problems.

The error message indicates that a communication error occurred during the transfer of the printout to the iPad.

A possible cause would be the iPad going to sleep halfway through the transfer.

A firewall may also cause the same error. The screenshot and console output show that Bonjour traffic got through fine. The firewall may however be blocking the transfer which happens on a different port.

Pierre Bernard
Houdah Software sarl
Houdah Software s. à r. l.

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
Argh!  I completely forgot that I'm running TCPBlock on my Air.  One tcpblock -a "ACTPrinter Mac" later and it's working just fine.

Thanks much!
0 0