Clicky

Jono
If I search a template using the custom URL method instead of from BlitzSearch it formats things differently & doesn't return results at all from a 2 word search.

In my example if I search for 'Time Capsule' from a search template that only searches for text files it doesn't return any results. Here is how the search looks

[img]http://www.iconaholic.com/drop/custom_URL_Search-20080724-073200.png[/img]



If I search the same template from the BlitzSearch it formats things differently & finds the documents I'm searching for as expected.

[img]http://www.iconaholic.com/drop/BlitzSearch_Search-20080724-073319.png[/img]


Could you make the custom URL search behave like the BlitzSearch?
0 0
houdah
Hi!

Thanks for reporting this.

This bug will be fixed in HoudahSpot 2.2.1

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
Jono
Thanks Pierre
0 0
Jono
Thanks for the new update

Was this problem supposed to fixed in the new 2.2.1 update? I still get the same problem where it won't return any results.
0 0
houdah
Hi!

This was supposed to be fixed in 2.2.1 and does actually work correctly here.

Please make sure you are running 2.2.1 and have removed 2.2 from your system.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
Jono
(Just to make sure) I've just trashed the app (even though it says it's 2.2.1) & re downloaded it, trashed the 2 plist files & the HoudahSpot folder in Application Support.

Setup a custom URL search to search the 'My Documents' template & searched a file in there with more than word in the name (That I'm positive is in my documents folder), & it doesn't return anything.
Is it still supposed to add the + signs between the 2 words? (e.g. a search for 'time machine' still says 'time+machine' if I do the search via LaunchBar & the custom URL).
0 0
houdah
Hi!

I just verified: the "+" signs appear when calling the URL from LaunchBar.

HoudahSpot expects the spaces to be encoded as "%20". LaunchBar however encodes them as "+".

The bug that was fixed was that "%20" was not correctly decoded. I never expected to see "+" signs.

I'll have to investigate. Sorry about that.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
Jono
Thanks Pierre
I'm glad the problem isn't only with my version.
0 0