Clicky

Kroozin
I recently purchased a Canon T2i and found that the CR2 files for the newer camera are different than the CR2 files made by the older Canon XSi.  

Just recently Aperture 3 came out with an update to their software to read the new CR2 file format.  I've tried to use Houdah to gain access to those files from Aperture and I get a couple of errors.

First, when I point to the folder in the Aperture library the files get imported with a JPG ending not with the CR2 raw ending (all the photos were raw and not jpeg so this was an error).  I tagged these files anyway but when I attempt to write to the EXIF I get a popup error message for each photo similar to:

Failed to tag image: IMG_xxxx.jpg (where x's are obviously the image numbers).

So the changes to Aperture to accomodate the new CR2 files are somehow not working with Houdah.

If I copy the pictures to a separate folder (not in Aperture library), Houdah can tag them fine and then I can import them into Aperture with geotagged data.

The issue just appears to be between Houdah getting files from the updated Aperture 3 library.
0 0
houdah
Hi!

Sorry to hear this is not working as expected.

The images showing up with a JPEG extension is however normal behavior. Aperture only published the JPEG previews. During EXIF export, HoudahGeo offers the option to "Tag Masters/Originals". With this option checked, HoudahGeo will find its way from the JPEG preview to the CR2 RAW file and tag that.

From the error message, I conclude that you are trying to tag the previews rather than the master file. This should work. But, in most cases, does not make much sense.

HoudahGeo will offer to notify Aperture of new metadata only if you are tagging master files.

Could you please check Console.app for further logging information during EXIF export? This should help me understand why tagging the JPGs fails.

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
Kroozin
Well looks like I had an OE problem (Operator Error).  I tagged the master files and things worked as they should.  I'll send you the Console.app file via email...

Thanks for the help.  


0 0