I saw the previous High Sierra topic by creativtext:
File Path Blank Mounted Drives in High Sierra

but my problem is slightly different, so I thought I'd start a new topic.

Since I upgraded to 10.13.2 a few days ago I noticed that searches would miss some files on mounted external drives, but its been inconsistent. I didn't see the file path problem mentioned in the other topic. HoudahSpot would simply miss some files but find others with the same search criteria on the same volume. Weird.

If I made a copy of the same file onto the same volume, it would find the copy but not the original. This got me thinking that anything indexed before I updated was not being found. But NEW files were being indexed.

Is that possible?

Is the fix using creativtext's Terminal commands or reindexing Spotlight?

And if the latter, what's the current procedure for reindexing external drives?
0 0
> Is the fix using creativtext's Terminal commands or reindexing Spotlight?

I am assuming that by "mounted external drives" you do mean directly attached drives (e.g. via USB).  In that case you don't need creativtext's solution which is for network volumes (including NAS), not directly 
attached external drives.

See for more details.   It seems to be a fairly obscure topic, based on googling results.

And if the latter, what's the current procedure for reindexing external drives?

I believe this method is still current:  System Preferences -> Spotlight -> Privacy. Drag your hard drive icon from the Finder onto the privacy window. Wait a bit (30?? seconds), and then drag it back out of the privacy window. This will trigger Spotlight to reindex your boot drive.
0 0
The Qumulo support link you provided has a great explanation of the problem with external drives and indexing though it's unclear why Apple hasn't fixed this yet - the article points out this problem started in Sierra.

Since I reported the problem here I did some more searching and found similar suggestions about re-indexing using Terminal elsewhere. You can use the mdutil command to turn Spotlight off, clear the index, obliterate all the Spotlight .profiles under root and then turn Spotlight on again.

The other method, as you mentioned, is dragging a volume in and out of the Privacy tab of the Spotlight System Prefs, though some people reported that they did not have success with that method until they created a completely new directory as root using

sudo mkdir -p /private/var/db/Spotlight-V100/Volumes/

This procedure is also outlined in more depth in the Qumolo article.

I plan to try this overnight since it may slow down my iMac while it re-indexes.

In the meantime I have resorted to the much slower Find Any File app - it works only on a per volume basis and has some other limitations when compared to HoudahSpot, but it doesn't rely on Spotlight indexes.
0 0
Thank you for the Qumulo link.

I would recommend you add double quotes around paths in the commands given in that article. This will allow the commands to work with volumes that have spaces in their name. E.g.

mdutil -s "/Volumes/My External Drive"

To check indexing status for all volumes and see the paths of the connected volumes:

mdutil -s -v -a

Note: the "/" path denotes your startup disk. E.g. “Macintosh HD”. Mounted volumes are usually under “/Volumes/“ 

To enable Spotlight indexing on a volume:

sudo mdutil -i on "/Volumes/My External Drive"

Erase and rebuild an index:

sudo mdutil -i off "/Volumes/My External Drive"
sudo mdutil -E "/Volumes/My External Drive"
sudo mdutil -i on "/Volumes/My External Drive"

Pierre Bernard
Houdah Software s. à r. l. 
Houdah Software s. à r. l.

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0

I decided to first use the simple Apple method of dragging volumes in and out of the Privacy section of the Spotlight prefs and was surprised when it worked. Some people had written on Apple forums that it didn't work for them with the High Sierra/external volumes problem, or only worked until they rebooted. I tried a reboot and it appears the external drives are still fully indexed - I searched for some fairly old files tht weren't showing up before and now Houdahspot/Spotlight finds them quickly.

Thanks for all the suggestions.

0 0