Clicky

opearson
Hi,
HoudahGeo (v2.6) doesn't seem to be able to load the most recently loaded photos in iPhoto'09 (v8.1.2).  Usually, I'm able to select the most recent photos for geocoding by using the "Add Images From Library" option, selecting my iPhoto library, and then navigating to either the newest event, or the "Last Import" option.  In neither case does the media browser show the last import into the iPhoto library.  Any suggestions?
Thanks! 
0 0
houdah
Hi!

The should not have been any change to the media browser in the latest update.

Here is what HoudahGeo does to get to your iPhoto images:
It reads ~/Library/Preferences/com.apple.iApps.plist 
There it finds one or more values for "iPhotoRecentDatabases"
This is typically a file URL like file://localhost/Users/pierre/Pictures/iPhoto%20Library/AlbumData.xml

Next the media browser loads the AlbumData.xml files. At the top of the file you will find the various albums. Towards the bottom, you will find the images.

Could you check if the missing images are listed and if yes, if they are actually linked to an album?

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
opearson
Thanks Pierre,
Unfortunately, I still can't get the most recent import to iPhoto to show up.  My iPhoto library has 6490 pics.  The most recent import added 10 pics.  In HoudahGeo, it only shows 6480 pics.  I've restarted both applications and the computer.  I can access all other photos in the library normally, just not the most recent ones.  Any other suggestions?
Thanks for your help!

0 0
opearson
Sorry, I forgot to mention also that I looked in the AlbumData.xml file you referenced, and the last album is listed, containing the 10 photos that don't show up in HoudahGeo.
0 0
houdah
Hi!

Do you have Keynote or Pages?

The applications come with their own media browser. This browser reads from the same file as the iMedia browser used by HoudahGeo.

If you can get Keynote or Pages to show the images, we will know that the AlbumData.xml is complete and need to search the problem within the iMedia browser.

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
opearson
Nope, I don't have either Keynote or Pages.
0 0
houdah
Hi!

Sorry for the delayed reply.

I am trying to think of a way to debug this. I cannot come up with anything but you sending me the AlbumData.xml file and me looking at why certain images get ignored.

Could you email me the file at info [at] houdah [dot] com?
Please let me know the name of one or more files you see in the XML but don't see in HoudahGeo.

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
opearson
Hi Bernard,
Thanks for getting back to me.  The problem seems to have corrected itself.  I tried again this morning, and all photos are showing up in the Houdah media browser.  I imported some additional photos today, and they show up immediately.  I'm not sure what might have been going on.
Thanks!
0 0
HoudahUser
I'm having a similar issue - tried finding the files in the Pages media browser - works fine there.  Doesn't show up in the HoudahGeo media browser.

Tried rebuilding the aperture database and reloaded the libraries in HoudahGeo but still doesn't work.

Running Aperture 3.1 with HoudahGeo 2.6.5 (3239).

Any ideas?
0 0
houdah
Hi!

Unfortunately, I have no explanation as to how this can be happening. So far, I suspected Aperture to be writing an incomplete XML file. Pages showing all images now rules out that explanation.

BTW, initial tests show HoudahGeo to be working fine with Aperture 3.1.

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
toofuzzy
Pierre,
Has this issue been resolved, I have had the Same Problem a couple of times, (again today) it does seem to Correct itself if you wait long enough.  I'm Using Aperture 3.1.1 and Houdah 2.8 (3492) 
0 0
houdah
Hi!

I still suspect this is a problem with Aperture. I have yet to see it myself.

Best,
Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
opearson
Hi Pierre,
This issue has appeared again.  I'm running HoudahGeo 3.2.1 and Aperture 3.3.2

The list of folders and projects in my Aperture library is not being updated in HoudahGeo.  This problem happens frequently, but if I wait for a while (an hour or so), the complete list of folders and projects eventually shows up.  This time, I've waited several days, restarted Apterture, HoudahGeo, and the computer numerous times, and am still not seeing all of the photos in my Aperture library.

Any suggestions?
Thanks in advance!
0 0
houdah
Hi!
 
Please check /Applications/Utilities/Console.app for error messages from HoudahGeo.
 
Here is what HoudahGeo does to get to your Aperture images:
It reads ~/Library/Preferences/com.apple.iApps.plist 
There it finds one or more values for "ApertureLibraries"
This is typically a file URL like file://localhost/Users/pierre/Pictures/Aperture/Aperture%20Library.aplibrary/ApertureData.xml
Next the media browser loads the ApertureData.xml file.
 
You may try deleting the ApertureData.xml. Aperture will create a fresh file.
 
Best,
Pierre Bernard
Houdah Software s.à r.l.
 
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0