Clicky

mkihr
Hello!

I am using Aperture Version 3.4.5 and HoudaGeo Version 3.4.4.
HoudaGeo is not loading any Aperture pictures in the Media Browser. The Aperture Library is there but there is no contents.
0 0
houdah
Hi!

Please go to Aperture > Preferences > Previews and make sure "Share previews with iLife and iWork" is enabled.

HoudahGeo gets the list of libraries from the com.apple.iApps.plist preferences files.
To access the file, hold the Option key as you select Library from the Go menu in the Finder.
This will take you to your Library folder. Within that you’ll find the Preferences folder which contains the com.apple.iApps.plist file.

That file points to recently used iPhoto and Aperture catalogs.
Actually it points to AlbumData.xml files within the iPhoto and Aperture catalogs.

Please check if this points at the current location of your catalogs.
If not, you can try to fix the entries, or trash the com.apple.iApps.plist.
A fresh file will be created the next time you launch Aperture or iPhoto.

Best,
Pierre Bernard
Houdah Software s.à r.l.


Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
mkihr
Hello!

Thats not the solution. I have done all that several times.
Setting in Aperture is there. I have even disabled and enabled that several times.
I have also removed the preferences file. Did not help.
The media browser works from garageband, iMovie, in the finder, ...
But it don't work in HoudaGeo.
I can load images with "Add Images" but not with the media browser.

Best regards
0 0
houdah
Hi!

Please check /Applications/Utilities/Console.app for error messages from HoudahGeo.

Please give the beta of HoudahGeo 3.5 a try.
This includes a few fixes to the media browser made while adding Lightroom 5 support.
The beta is linked from another post in this forum.

Also, if you like, please email me the AlbumData.xml file

Best,
Pierre Bernard
Houdah Software s.à r.l.



Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
mkihr
There are no messages at all in console from HoudGeo. (~/Libray/Logs/...)
Where is that AlbumData.xml file?

0 0
houdah
Hi!

com.apple.iApps.plist will tell you where the file is.

It is inside your Aperture Library package.
Right-click "Aperture Library.aplibrary" and select "Show Package Contents"
The AlbumData.xml file is at the top level.

Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
mkihr
Attached is the requested file.
But there is no AlbumData.xml file.
The name of the file is ApertureData.xml.
The contents of this file might be not as it should be. For instance: 
Application Version is 3.2.3 but the Version of Aperture is 3.4.5
File is renamed to ApertureData.xml.txt in order to attach it.
0 0
houdah
Hi!

Indeed, the file should be named ApertureData.xml. It's the iPhoto file that is named AlbumData.xml.

There is something very wrong with the file you sent me.
There is the application version number. This would indicate that Aperture has not used the file in a while.
More importantly: the file is empty. There are just a few placeholders for the default albums.

Please make sure the file is from the actual Aperture library you are currently using.

If it is, quit Aperture, backup the ApertureData.xml file and move it out of the way.
Aperture should create a new one.

For comparison:

- Your ApertureData.xml file is 4 KB
- Mine is 13 MB
- My Aperture library holds 17'000 photos
 
Best,
Pierre Bernard
Houdah Software s.à r.l.
Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0
mkihr
Hello!

Thanks for the help. Problem is obviously in the Aperture database. After moving from iPhoto to Aperture it was corrupted.

Regards
0 0
Jamin11
I have a similar problem.
 
Aperture Version 3.6
Houdahgeo Version 4.2.4 (11077)
 
No aperture library appears in media browser after trashing both AlbumData.xml and restarting Aperture ( which generated another AlbumData.xml file NOT an ApertureData.xml file) and Trashing the com.apple.iApps.plist and restarting Aperture ( which generated another com.apple.iApps.plist file)

If it is a corrupted Aperture database, how can I fix it? Was mkihr able to fix it?
 
Help?
 
0 0
houdah
Hi!

Instructions for repairing the Aperture database can be found here: https://support.apple.com/en-us/HT201289

Did you share the library between Aperture and iPhoto?
If so, try opening it in iPhoto and see if HoudahGeo lists it as iPhoto library.

Can you email me the com.apple.iApps.plist and AlbumData.xml files at support@houdah.com?

Best,

Pierre Bernard
Houdah Software s.à r.l.

Houdah Software s. à r. l.
https://www.houdah.com

HoudahGeo: One-stop photo geocoding
HoudahSpot: Advanced file search utility
Tembo: Easy and effective file search
0 0